We've upgraded our Swift support to the latest version, Swift 4. Swift is a general-purpose, compiled programming language developed by Apple. 

Useful for assessing developers working with iOS, macOS, watchOS, tvOS, or Linux, Swift 4 is enabled across the Codility Task Library, so that you can decide whether or not you'd like candidates to have the ability to solve their test using Swift 4. 

As of 2nd January 2019,  we will be upgrading all versions of Swift in our platform to Swift 4, and previous versions (Swift 2 and Swift 3) will no longer be available. 

If you've currently enabled Swift on your tests, they'll be updated automatically to Swift 4 on January 2nd. 

If you have any questions, feel free to contact us at support@codility.com. 

Did this answer your question?